Status: Resolved and Monitoring Start Time: 19.02.2026, 13:30 UTC End Time: 19.02.2026, 16:00 UTC Affected Systems: Multiple services running in our Kubernetes environment
What happened We experienced widespread degradation in our Kubernetes environment that caused intermittent service unavailability. The primary symptoms were increased latency, connection errors, request timeouts, and DNS resolution failures for some components.
Impact Users may have experienced intermittent outages, slow responses, or failed requests across multiple services.
What we're doing / Mitigation We identified infrastructure nodes that were not handling DNS/networking correctly and replaced them to restore stability. We also verified DNS services recovery and continued monitoring while workloads stabilized.
Current status All services have recovered and are operating normally. Error and timeout rates have significantly decreased. We are continuing to monitor closely to ensure full stability and to confirm there is no recurrence.
Next update We will post another update if conditions change or once we confirm full resolution.
Posted Feb 19, 2026 - 16:01 UTC
Identified
We identified that problem is related to DNS/Network and we are actively working on resolving the issue.
Posted Feb 19, 2026 - 15:23 UTC
Investigating
We are experiencing system degradation and we are actively investigating the issue.
Posted Feb 19, 2026 - 13:41 UTC
This incident affected: API, Customer Hub (Portal), Partners API, and Evidence Submission.