Production Service Partially Impaired

Incident Report for Justtai

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:40 UTC

Monitoring

Update - Affected services are starting to recover along with AWS.

Please check the AWS Status page for the latest updates: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 20:04 UTC

Update

Update - Justt App Services is experiencing increased processing delays in the US-EAST-1 regions along with degraded performance in Triggers updates.

We are closely monitoring the situation and the official AWS status page.

Please check the AWS Status page for the latest updates: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 19:28 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 19:27 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:28 UTC

Investigating

Issue under investigation
Posted Oct 20, 2025 - 07:28 UTC
This incident affected: API, Customer Hub (Portal), Partners API, and Evidence Submission.